Community Forums > General > General Discussion > Where to get the game? So I can start to play again

Where to get the game? So I can start to play again

 combatmite3


Grup: Standart Üyelik
Katılım Tarihi: 07/07/2007
Gönderiler:5
Gönderildi 13/12/2017 - 16:40
Hi

Would someone kindly point me in the right direction where I can download the game and play age of empires 2 the conquers.

I used to have the disk and then update with patches to play but I have consequently lost the disk.

Please help!

Thanks

Bağlantı | Yanıt | Alıntı
 +chris@voobly


Grup: Server Yöneticisi
Katılım Tarihi: 03/10/2007
Gönderiler:7443
Gönderildi 13/12/2017 - 17:08
When you buy Age2HD on Steam, you can also play AOC on Voobly.
https://support.voobly.com/display/vkb/KB1054+Clean+installation+of+Aoe2HD+with+compatibility+patch
Bağlantı | Yanıt | Alıntı
 combatmite3


Grup: Standart Üyelik
Katılım Tarihi: 07/07/2007
Gönderiler:5
Gönderildi 13/12/2017 - 17:33
Thanks Chris

And does Age of empires 2 HD include the conquers and mean that you can play against people that do not have the HD version?

Cheers

Ben
Bağlantı | Yanıt | Alıntı
 +chris@voobly


Grup: Server Yöneticisi
Katılım Tarihi: 03/10/2007
Gönderiler:7443
Gönderildi 13/12/2017 - 17:38
Hi Ben

yes, that's correct. Our compatibility patch will allow you to play AOC when you have Age2HD.
Bağlantı | Yanıt | Alıntı
 combatmite3


Grup: Standart Üyelik
Katılım Tarihi: 07/07/2007
Gönderiler:5
Gönderildi 13/12/2017 - 17:45
Thanks Chris

And I can see from Steam that there are a lot of new add ons, are these compatible or would you just order the £14.99 version?

Thanks

Ben
Bağlantı | Yanıt | Alıntı
 +chris@voobly


Grup: Server Yöneticisi
Katılım Tarihi: 03/10/2007
Gönderiler:7443
Gönderildi 13/12/2017 - 17:58
If you want to play those new civs on Voobly (called AOC Wololo Kingdoms) you better purchase Age2HD + all DLCs. :)
http://www.voobly.com/gamemods/mod/860/WololoKingdoms
Bağlantı | Yanıt | Alıntı
 OmegaMale


Grup: Standart Üyelik
Katılım Tarihi: 21/06/2014
Gönderiler:2
Gönderildi 14/12/2017 - 19:02
Does the patch make the game compatible with custom content on voobly, like mods?


Bağlantı | Yanıt | Alıntı
[1]
1 7 arasından ilk 7 - 0 görüntüleniyor
Foruma Git:
1 Kullanıcı(lar) Bu sayfaya bakıyor (30 dakika içinde)
0 üye, 1 ziyaretçi

Şu an en popüler:
Geçen haftaki en aktif konular:
CBAv22 (33 gönderi)
CBA PathBlood 1.5.1 (7 gönderi)